my service prvdoier does not support 4.5 i currently have 4.3 so does this mean i can't upgrade without messing up my phone or is this just some legal junk that blackberry and my service prvdoier are fighting over? 4.3 works fine i just can't get these document viewers without 4.5I guess what i'm asking is: should i be concerned about my prvdoier not supporting the upgrade or can i download anyway without complications?
--Romina Sun Nov 24 04:44:12 2013
What a plersuae to find someone who thinks through the issues
--Mitch Mon Nov 25 07:56:06 2013

Comments Disabled... (Thanks Dirty Rotten Spammers)
Feel free to write kirkjerk at gmail dot com!